Startseite > Computers and Internet, Microsoft > Patch Day – Reboot – crcdisk.sys

Patch Day – Reboot – crcdisk.sys


Am letzten Mittwoch war Patch Day. Alle Systeme durchgepatcht. Und nur 2 Probleme. Das Erste war ein Patch für den ISA-Server 2006.  Danach war kein VPN-Zugriff möglich. Aber das Problem war noch in Erinnerung. Patch entfernt, und siehe da. Alles ging wieder. Der letzte Server war ein Server, der als HOST für verschiedene Hyper-V Gäste fungiert. Und auch hier war ein Reboot notwendig. Der Server braucht schon eine Weile, bis er wieder alle Gäste durchgestartet hat. Aber nichts passierte. Der Gang in den Serverraum war unumgänglich. Ein Blick auf den Monitor, der Start-Bildschirm lief und lief und lief. Und ab hier folgten Stunden des Suchens. (Hier die Kurzversion)Zur Konfiguration:

Server Intel S5000PSL
Prozessor 2x Xeon Quadcore E 5430
RAM 18 GB
Controller 1 Intel Embedded Server RAID Technologie II
Disks 2x 160 GB RAID 1 (darauf das OS)
Controller 2 Adaptec 5805
Disks 8x 750 GByte RAID 5
OS Windows Server 2008, 64 BIT

Nach dem manuellen Reset und erneutem Reboot kam der Bildschirm und ich wählte Safe Mode. Die verschiedenen Device-Treiber werden aufgelistet und der letzte geladene Treiber war crcdisk.sys. Auf zur Suche im Internet, Zu viele Einträge. Startprobleme bei Vista und Windows Server, aber auch XP. Hier komme ich nicht weiter.1. Versuch: Zuerst einmal habe ich die 8 Disks abgeklemmt., den Adaptec-Controller aber im System belassen. Reboot. Keine Änderung.2. Versuch: Das RAID1 System (von dem ich bisher gebootet habe,) abgeklemmt. Eine neue Disk angeschlossen. DVD mit dem OS eingelegt. Im System sind jetzt also immer noch 2 Controller, der Intel-Controller mit einer Festplatte, der Adaptec Controller ohne Disks und ein DVD Laufwerk. Reboot. Das Betriebssystem wird von der DVD geladen, die Treiber von der DVD geladen. Bis zu den 100%. Dann sollte der Wechsel in den graphischen Bildschirm zur Sprachauswahl erfolgen. Was nicht passierte. System hängt.3. Versuch: Habe den Adaptec-Controller ausgebaut. Hingen ja keine Festplatten mehr dran. Reboot. Nur mit dem eingebauten Controller und der angeschlossenen Festplatte und dem DVD-Laufwerk wird das OS geladen. Und jetzt das erstaunliche: Ich komme zum graphischen Bildschirm zur Spracheingabe. Sollte der nicht mehr eingebaute Adaptec-Controller ein Problem versuchten? Zur Abgrenzung dieser Frage erneuter Umbau.4. Versuch: Der Adaptec-Controller bleibt erst einmal ausgebaut. An den internen Intel-Controller schließe ich die 2 RAID1 Disks wieder an. DVD aus dem Laufwerk nehmen. Reboot. OS startet durch. Hat der Adaptec-Controller einen Schaden?5. Versuch: Zuerst einmal im Internet bei Adaptec in der Wissensdatenbank suchen. Grausam. Jede Frage dauert ewig. Die Controller mögen ja super sein. Aber Adaptec sollte einmal in gescheite Software und oder Hardware investieren. Das macht kein Spaß. Na ja, bleibt noch die Hotline. Ohne TSID-Nummer geht gar nix. Sagt die Website. Wo um alle Welt habe ich diesen Key? Ich hebe solche Sachen eigentlich auf. Aber nix da. OK, Serien-Nummer geht auch. Ist ja aufgedruckt auf dem Controller. Kann man auch auf der Adaptec-Seite, nachdem man sich registriert hat (dauert auch ewig), eingeben. Dann die Eingabe: Prüfung. Warten. Warten. Es handelt sich nicht um ein gültiges Adaptec-Produkt. Klasse. Ist wohl ein Fehler in der Datenbank. (Vielleicht auch nur ein TIME-OUT). Na egal. Ruf ich halt an. Nummer heraussuchen und Hinweis entnehmen. Heute ziehen wir um .Erst wieder am nächsten Werktag. Oder in USA. Aber nur zu den normalen Arbeitszeiten. Also 3 h warten. Dann anrufen. Hätte ich gleich machen können, weil es mir nichts bringt. Ein Sprachautomat fordert mich zur Eingabe der TSID auf. Ohne TSID keine Auskunft. Gefangen im Kreislauf. 

Der Hinweis im Adaptec-Installationshandbuch, das BIOS des Controllers zu überprüfen ist doch vielleicht eine Alternative. Wieder auf die Adaptec-Seite. Die aktuelle Firmware des Controllers 5805 downloaden. Diskette erstellen. Diskette erstellen? Habe keine Diskette mehr. Also wird ein Memory-Stick mit bootbarem MS-DOS erstellt und die Firmware-Dateien erzeugt.6. Versuch: Adaptec Controller 5805 wieder eingebaut. Vom Memory-Stick gebootet. Prüfprogramm gegen das Controller BIOS laufen lassen. Ergebnis. Alles OK. Der Controller zeigt bei 20! LEDS natürlich auch keinen Fehler an.Resümee: Steckt der Adaptec-Controller im Server, funktioniert das Booten nicht mehr. Das Booten mit Windows Server 2008. Also nächster Versuch.7. Versuch: interner Controller mit neuer Disk, Adaptec Controller eingebaut, ohne Disks, Booten von DVD mit Windows Vista. Gleiches Ergebnis: keine Installation möglich. Auch fast logisch. Der Kernel ist ja identisch.8. Versuch: interner Controller mit neuer Disk, Adaptec Controller eingebaut, ohne Disks, Booten von DVD mit Windows Server 2003 R2. Ergebnis: Installation möglich. Aha!. Also liegt es nicht am Adaptec-Controller.  Sollte das Problem am BIOS des Intel-Servers liegen. Oder an der Firmware des eingebauten Intel-Controllers? Ab ins Internet. Zum Glück ist hier rund um die Uhr geöffnet. Die Suche bei Intel gestaltet sich einfach. Aber die DOS-Utilities bringen jede Menge ReadMe-Dateien mit sich, die man, wenn es um BIOS geht, lesen sollte. Jede Menge Ausnahmen. OK. Download der gezippten Datei. Entpacken auf den DOS-Stick.9. Versuch: Alles ausgebaut. Booten vom Dos Memory Stick. Altes BIOS wird überschrieben. Diese Anweisung muss noch einmal wiederholt werden. Done. Jetzt die Firmware des Controllers. Done. Jetzt wird es spannend. In den BIOS-Einstellungen müssen wieder ein paar Einstellungen gesetzt werden. Ausschalten.10. Versuch: An den eingebauten Intel-Controller wird eine leer Disk angeschlossen, der Adaptec-Controller eingebaut, aber keine Disk angeschlossen. Im DVD-Laufwerk liegt die OS Windows Server 2008, von der ich booten will. (siehe Versuch 2). Und siehe da, jetzt bleibt das System nicht mehr hängen. Ich kann eine Sprache auswählen und könnte die Installation fortsetzen. Der Adaptec-Controller ist also nicht der Verursacher.11. Versuch: An den eingebauten Intel-Controller werden die 2 Disks (Raid1) wieder angeschlossen. Dieses System enthält ja alles, was ich brauche. Der Adaptec-Controller bleibt im System. Booten. Alles fein. Das Betriebssystem startet. Herunterfahren. Mittlerweile ist es 3 Uhr in der früh. Aufatmen.12. Versuch: Der Adaptec-Controller erhält seine 8 Disks wieder. Welche Kabelpeitsche an welchen Kanal, der Controller hat ja 2, angeschlossen war, weiß ich nicht mehr. Ist aber egal. Habe ich im Handbuch gelesen. Und tatsächlich. Er findet die RAID 5 Konfiguration und auch die Hyper-V Maschinen starten wieder. Alles automatisch.Dies ist die Kurzversion. Nicht aufgeführt ist jede Menge Zeit, die ein Server braucht, der sich von BIO zu BIOS hangelt. Jede Menge Zeit bei der Suche im Internet. Die Versuche, die ich hier nicht aufgelistet habe, waren Versuche mit unterschiedlichen BISO Einstellungen. Dazwischen lagen ein paar Telefonate mit Freunden, die ich um Hilfe gebeten habe. Es hat sich aber immer nur bestätigt, dass ich richtig lag.Danke Thomas L., Thomas W. und Bernd S., dass ihr mir zugehört habt.jetzt läuft das System wieder. Was für ein Tag. Was für eine Nacht.

 

 

  1. Es gibt noch keine Kommentare.
  1. No trackbacks yet.

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s

%d Bloggern gefällt das: